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MANUAL FOR USING THE ABIR/ABAR MODEL


The version PS-I-28 of the ABIR/ABAR model is downloadable from Ian Lustick’s homepage (http://www.ssc.upenn.edu/polisci/faculty/bios/lustic.html) on the University of Pennsylvania Department of Political Science website.  Download time is no more than a few seconds.  Versions are not available for MAC users though if a windows or NT environment can be emulated the model should work. Please note that for the purposes of applying the model to deliberative democracy, entrepeneurs are to be thought of as “opinion leaders” and basic agents are to be understood as ordinary citizens.

Guide to Program Use

1. Open program and a default landscape will be displayed (the "active" landscape). 

2. The time should say zero in the bottom left corner.  If it doesn't, click the Action tab and then "reseed."  This will randomize the distribution of colored squares or agents drawing on all available identities--one color per identity.  

3. If the "Identity View" circle is checked, the display indicates which identity is currently activated by each agent (colored square).  If the "Tension View" circle is checked the display indicates variation in the amount of difference each agent encounters in his neighborhood.  Yellow indicates an agent activated on a particular identity sees no other agents activated on that identity in his Moore neighborhood (the surrounding eight squares).  Bright green indicates the agent is fully surrounded by agents activated on his activated identity.  Various shades of red and dark green show intermediate amounts of difference, or "tension."  

4. At the bottom of the display you will note X and Y coordinates, which indicate which agent the pointer is designating.  To the right of these coordinates is indicated the identity activated by that agent (A=activated identity) and the list of identities contained within the cache, or repertoire of that agent (C={1,3,4, etc.}).  The influence of the agent--the forcefulness with which it affects those in its neighborhood, is also indicated.  I=1 means an influence of 1.  I=2, typical of an entrepreneur (Ent) agent, means an influence of two.  These influence levels can be adjusted for groups of agents or individual agents using the Prototype Agent dialogue box.  (See below.)

5. By clicking on the Run button a “history” is created.  Y

ou will note time passing in the bottom left hand corner and you will note processes of clustering in the identity view.  If you toggle to tension view, by checking the “Tension View” circle, you will note the emergence of areas of green out of the mass of yellow and red.  The absence of green at time 0 is the natural result of a randomized distribution of agents.  Clicking on "Step" allows you to monitor changes in the landscape one time slice at a time.  Clicking on "stop" while the program is running will, stop the program (which can then be restarted or reseeded and begun again).

6. Various settings can be controlled in order to experiment with the dynamics of differently constructed landscapes and populations.  Many of these settings are made in the "New Model" dialogue box, accessed by clicking the "File" tab in the upper left hand corner. 

7. Click on the File tab in the upper left hand corner, then click on "New Model," and settings for this default landscape will be displayed.  When ABIR is loaded the settings for the landscape displayed default to those associated with the last landscape used by the program before it was closed. 

8.  Each setting can be changed by inserting a cursor in the box and changing the number. 
The number in the Basic Agent (BA) box is the size of the identity repertoire, that is the number of identities associated with any specific agent in the landscape (including the agent's activated identity).  The number in the Entrepreneur (Ent) box, which must be larger than the number in the BA box, is the number of identities associated with any Ent agent in the landscape.

9. The percentage or density of Ent agents in the landscape (agents with black dots in their centers) can be adjusted by setting the number in the "Ratio of entrepreneurs" box from 0.0 to 1.0 (0% to 100%).  

10. The number of available identities is the number of different identities in the world.  In other words, this is the pool of identities that exists.  It is from this pool that are drawn the identities used by the ramdomization process (the “reseed” command) as it assigns identities to be activated and included in the repertoires of all agents in the landscape.   Although no agent will ever be able to have all available identities in his repertoire, no identity can exist in the repertoire of an agent that is not in this pool of identities.”   Therefore the number of "available identities" must be set to be larger than the number of identities in the repertoire of any agent in the landscape.  The maximum number of available identities is 20.

11. The shape and size of the landscape are determined by setting the "Landscape Dimensions," indicating how many agents will be arrayed in the rows (width) and columns (length) of the landscape.  The "model" box allows choice of various geometries for the shape of the landscape:  Torus, Square, Cylinder, Four Squares, Island, and Isthmus.   In the Torus display the top wraps to the bottom and the sides wrap to one another. In the Cylinder display the sides wrap to one another.  (By using the prototype agent function, accessible by clicking the "View" tab, landscape shapes and geometries can be customized in rather intricate ways.  See below, paragraphs) 

12. Two settings control the pace and extent of fluctuation in the signals sent to all agents in the landscape as to how advantageous or disadvantageous it is to be activated on any particular identity at a particular time slice--that is how "biased" the world is for or against that identity.  These settings are accessed by clicking the "View" tab and then clicking "options."  

13. Within the options dialogue box is a tab for "Bias Volatility."  This number can be set from 0 to 1 and determines how likely it is at any time slice any particular identity will be eligible for change in the bias assigned to it.  Low settings, e.g. .001, produce slow rates of change in bias assignments.  High settings, e.g. .05, produce rapid rates of change.  

14. The Min Bias and Max Bias settings permit designation and change in the range within which the biases can vary, no matter how often they may change--in other words no matter how volatile the environment is.  Settings of -1 to +1 produce rather sluggish or stable worlds, -3 to +3 produce much more dynamic histories (in part dependent on the volatility settings with which they are combined).  Maximum and Minimum range settings need not be symmetrical, however.  For example, range can be set to –2,+1. Once entries have been made, the "Apply" tab must be clicked for them to take effect.  

15. Changes in bias settings  can be done in the midst of an ongoing history, not only at time zero.  By using the “stop” command to interrupt a history in progress and then increasing one or more of the bias settings, a "punctuation" of environmental turbulence can be produced.  After a desired interval the settings can then be returned to their levels before the "punctuation."

16. Various characteristics of the evolving landscape are monitored by the program and can be viewed while the run is in progress and after it is stopped.  By clicking the View tab and then the "Identity Information" option a window is opened which displays each identity present within the landscape at time zero.  These are listed by number and color.  Data displayed in this window indicate the number of agents currently "Activated" on that identity, the number currently containing that identity within their repertoires ("Subscribed"), the bias currently associated with that identity, and the "average tension" being experienced by agents activated on that identity.  By clicking on the tool bar for "Identity," "Active," "Subscribed," "Bias," or "Average Tension," the sorting of the display is changeable.  By clicking on the colored box associated with the different numbered identities the agents activated on that identity in the landscape are lit up in white and can be easily seen for purposes of studying distributional patterns.  To remove the white highlighting click anywhere else in the Identity Information dialogue box.

17. Statistical information on characteristics of the evolving landscape is available by clicking the View Tab and then the "Statistics Window."  The Statistics Window contains point and click options for the display of settings currently in operation (Model Parameters), the number of identities whose activated agents comprise various proportions of the landscape (Activated identity distribution), the number of identities whose subscribed agents comprise various proportions of the landscape (Subscribed identity distribution), the number of activated and immutable agents (Total agents), and the tension level across the entire landscape (Total tension), and the current time period (Time). [Note, blackened agents are immutable and inactive--they cannot change and do not express an identity.]

18. Many of the experiments run with the ABIR model entail customization of landscapes by inserting barriers, borders, or particular distributions, patterns, or densities of agents featuring particular activated identities, repertoires, influence levels, etc.  Most of these operations are accomplished with the "Prototype Agent" function, allowing the experimenter to seed the landscape with agents of his/her design.

19. The Prototype Agent dialogue box is accessed by clicking the Options tab and then the Prototype Agent tab within the Options menu.  The window which opens displays the activated and subscribed identities of the specific agent whose coordinates on the landscape are specified at the bottom left of the window. The default coordinates are 1,1, but by pointing at another agent on the landscape and clicking the "obtain" button, the  repertoire of identities of any specific agent can be displayed.  For purposes of customizing the landscape it does not matter which agent's coordinates are displayed.  (Tip:  The Prototype Agent dialogue box is visible simultaneously with the active landscape by using the windows resizing button on the upper right-hand corner of the windows display.)

20. To use the Prototype Agent dialogue box to change the activated and/or subscribed identities of  agent, use the pointer to drag and drop colored squares from the rectangle on the right labeled "cache" to the rectangle on the left labeled "pool," and vice versa (dragging and dropping colored squares from the "cache" to the "pool").  The "pool" contains all the identities (colors) present across the landscape plus a "random" feature.  The identity at the top left of the cache, and labeled "active" is the activated identity.  

21.
The agent's identity weight, or "influence" (on those agents in its neighborhood) can be set by using the "influence" box in the bottom right corner of the Prototype Agent dialogue box.  The default setting of "-1" indicates an absolute value of "1," which is the normal influence level for a basic agent.  Monster, or charismatic agents, can be created by increasing the influence level.  The standard influence level for entrepreneurs is "2."  It is important to remember that if seeding with agents that have a repertoire the size of that of an entrepreneur (as specified in the New Model dialogue box of an active landscape), seeding will produce agents with the black dot in their center--indicative of an entrepreneur agent.  But in fact, unless the influence level is set at "2," the "entrepreneurs" seeded using Prototype Agent will only have an influence level of "1."  In ABIR these agents are deemed “innovators” since they respond with agility and speed to new opportunities but do not exert more than usual influence over the identity decisions of their neighbors.

22.
The custom designed agent can be substituted for any agent in the landscape by pressing the "Seed" button and then clicking on the location where the newly designed agent is to be placed.  Areas of the landscape can be "painted" with the prototype agent by clicking, holding the left mouse button down, and then dragging the pointer down and/or to the right.  The proportion of this painted area that is actually "seeded" with the customized agent is determined by the number typed within the "seed ratio" box--a number that can vary from 0.0 to 1.0.

23.
Two other features permit design and seeding of "immutable"  or “fanatic” agents--agents which can never change (no matter what biases are registered and no matter what the identity weights in their neighborhoods) and "inactive" or “apathetic” agents--agents who change in normal ways but exert no influence on their neighbors.  These features are implemented in a prototype agent by clicking on buttons within the “Attributes” box .  These buttons have down arrows and are to the right of small windows labeled "immutable" and "inactive." Clicking on these arrows yields three options:

"unchanged":  meaning that the prototype agent, when seeded, will take on the attribute(s) of the agent for which it is substituting;

"set":   meaning that the prototype agent, when seeded, will be immutable, inactive, or both (if both are "set");

"unset": meaning that the prototype agent, when seeded, will reverse an "immutable" and/or "inactive" setting already present in the agent for which it is substituting.                              

By "setting" the prototype agent to be both immutable and inactive, boundaries, barriers, and shapes can be drawn into the landscape.  They appear as black squares.

24. For research purposes an important feature of ABIR is its ability to record information about each time step in the history of a landscape.  This can be accomplished in two ways.   Using the “save landscape” command, accessed through the File button, a dialogue box is opened.  A landscape at any particular point in time can be saved under whatever name is designated in this file name dialogue box.  This landscape can then be recalled using the load landscape command, accessed through the File button.  All information is preserved and can be accessed using the View-Options, View-Identity, or View-Statistics windows.  

25. It is also possible to save information about multiple time-steps in a history, for example, from 1-25, 1-1000, etc.  Access the Start Log command, through the File button.  Click the Start Log command before clicking the Run button to begin a history.  In the dialogue box that appears type a name for the file that will contain the data about the history about to be produced, and click “save.”  Next click the “Run” button.  Let the history of the landscape proceed as long as desired, then click “Stop.”  Then click File and “close log.”  The “csv” file thereby created is readable by Excel and can be integrated within an excel workbook.  The file will list all the information about the landscape and its biases at each time step in the history, except the spatial location of activated and subscribed identities.

26.  For experimental purposes it is very important to be able to produce multiple histories that are identical in certain respects and different in others.  Using the Run command from the Start Button in Windows it is possible to instruct ABIR to produce specified numbers of histories with settings determined by the experimenter and to either save the results of those histories as a series of landscapes or as within logged csv files, or both.  For instructions in using the scripting function see the forthcoming manual “Scripting Tools for ABIR 28.”

